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How I Created a Graph for My Single Case Design Dissertation 
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June 2, 2013 

There are times when I wonder how many clueless people Microsoft employ just to make things 

confusing and needlessly difficult. I recently discovered that Microsoft has no idea that researchers need 

to create charts that clearly document their findings and have spent the last couple of months battling 

with Excel 2010. I was able to get things to work adequately for my needs while I was gathering data 

(although with considerable effort). As I am now at the conclusion of my data collection, I’ve begun to 

deal with things again only to realize just how much I hate clueless programmers who live in their own 

little world and make things needlessly complex.  Although my research is using a multiple-baseline 

across-participants single-case design (which will require many of the graphs that are very similar to the 

one graph provided in this paper), the challenge of getting Excel to do exactly what I need has been 

nearly impossible. After I overcame the final problem I was having (I wanted to create custom labels for 

the X axis) today, thanks to a M$ newsgroup. I decide to waste another day creating this instruction 

sheet for me, just so I won’t forget over the next month or so that I’ll be spending a lot more time with 

Excel. With that in mind, I’ve made NO EFFORT to proofread or edit anything here as I created it just for 

my own needs. If someone else wants to use it – great! If not, then it’s not a big deal. So . . . here’s 

“How I Done Did It!” 

It’s necessary to prepare data correctly in Excel first. To do so, enter data in the following format (see 

below). Header names should include: 

 Session # (this column must be equal to [or greater than] the number of sessions that subject 

who has completed the most will finish. In other words, if there are six subjects and subject 6 

will have the most [let’s say 10 baseline sessions and 40 intervention sessions, for a total of 50 

sessions] then ALL charts for EVERY subject should list 50 sessions [even though subject 1 may 

only have completed 3 baseline and 40 intervention sessions, for a total of 43]. This is required 

in order to appropriately label the X axis on each graph – more on this later.   

 Split data into separate columns for each phase (this will permit the creation of trend lines 

later) 

 A “Dummy X” column with all values set to 0 

 Columns for the Phase Name (e.g., Baseline, Phase 1, Phase 2, Phase 3, etc.) and columns for 

Phase Line X and Y values. 

 A column for X Axis Labels (more on this later). 
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The data should appear as follows: 

 

  

Session Words Correct # of Errors Words Correct # of Errors Words Correct # of Errors Words Correct # of Errors Dummy X Phase Phase Line X Phase Line Y X Axis Labels

1 13 1 0 Baseline B1

2 8 9 0

3 18 6 0

4 12 4 0 Phase 1 3.5 40 1

5 22 2 0

6 16 1 0

7 17 1 0

8 17 3 0 5

9 23 0 0

10 17 5 0

11 11 10 0

12 21 4 0

13 13 7 0 10

14 17 5 0 Phase 2 13.5 40

15 18 2 0

16 16 3 0

17 18 6 0

18 23 2 0 15

19 24 0 0

20 20 7 0

21 13 6 0

22 12 11 0

23 18 5 0 20

24 14 9 0

25 15 8 0

26 21 1 0

27 17 6 0

28 25 3 0 25

29 22 3 0

30 23 2 0

31 21 8 0

32 23 3 0

33 24 3 0 30

34 19 3 0 Phase 3 33.5 40

35 20 2 0

36 11 5 0

37 17 2 0

38 21 1 0 35

39 18 4 0

40 22 0 0

41 22 3 0

42 27 2 0

43 18 1 0 40

44 0

45 0

46 0

47 0

48 0 45

49 0

50 0

Sum 39 16 169 37 384 93 195 23

Mean 13.00 5.33 16.90 3.70 19.20 4.65 19.50 2.30

Baseline Phase 1 Phase 2 Phase 3

Student 1
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Highlight the following columns: 

 

Session Words Correct # of Errors Words Correct # of Errors Words Correct # of Errors Words Correct # of Errors Dummy X

1 13 1 0

2 8 9 0

3 18 6 0

4 12 4 0

5 22 2 0

6 16 1 0

7 17 1 0

8 17 3 0

9 23 0 0

10 17 5 0

11 11 10 0

12 21 4 0

13 13 7 0

14 17 5 0

15 18 2 0

16 16 3 0

17 18 6 0

18 23 2 0

19 24 0 0

20 20 7 0

21 13 6 0

22 12 11 0

23 18 5 0

24 14 9 0

25 15 8 0

26 21 1 0

27 17 6 0

28 25 3 0

29 22 3 0

30 23 2 0

31 21 8 0

32 23 3 0

33 24 3 0

34 19 3 0

35 20 2 0

36 11 5 0

37 17 2 0

38 21 1 0

39 18 4 0

40 22 0 0

41 22 3 0

42 27 2 0

43 18 1 0

44 0

45 0

46 0

47 0

48 0

49 0

50 0
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Click on “Insert” > “Scatter” (for Scatter Charts) > “Scatter with Straight Lines and Markers.” That will 

create the following chart: 

 

 

 

Resize as desired (can be further adjusted later): 
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Adjust X and Y values and tic marks as needed. 

To adjust Y axis: 

 Double click on labels – this will place a box around all Y axis labels and open up a “Format Axis 

Window: 
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 Change values as needed (I use “fixed” values to ensure that things don’t change and also set 

Axis Value to 0): 
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 Repeat for X Axis (with the understanding that some of this will change later when creating 

custom labels). Here’s an example: 

 

 
 

  



8 

The graph will now appear as: 

 

 

 

Add axis labels: 

 

 For X Axis: Click on “Layout” > “Axis Titles” > “Primary Horizontal Axis Title” > “Title Below Axis,” 

enter the label for the X Axis, then hit “enter.” The graph will now appear as: 
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 For Y Axis: Click on “Layout” > “Axis Titles” > “Primary Vertical Axis Title” > “Rotated Title,” enter 

the label for the Y Axis, then hit “enter.” The graph will now appear as: 

 

 
 

 Resize graph if needed. 

Remove “fill” and borders from graph. 

 Click anywhere on graph so that has focus. Make sure that no labels or other objects are 

highlighted. 

 Right click on graph, select, “Format Chart Area” 
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 Select “No fill” 
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 Click on “Border Color” then “No line” 

 

 
 

 Click “Close” 
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 Next, click on the graph (where the data has been plotted). Right click then select “Format Plot 

Area.” The “Format Plot Area” window will display. Select “No fill”: 
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 Click on “Border Color” then “No line” 

 

 
 

 Click “Close” 

At this point, the graph is transparent and the normal Excel grid lines will appear behind the graph. 
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Remove horizontal lines (also called “Format Major Grid Lines), as per APA, from graph. 

 Double click on one of the grid lines. Small circles will appear on the ends of all grid lines. 

 Hit “Delete” key – all grid lines will disappear”: 

 

Now that the Major Grid Lines are gone, there seem to be too many tic marks on the Y axis. The graph 

can be removed or resize the graph. Removing the minor tic marks will look like this (see instructions 

listed above): 

 

This graph shows two items, “Words Correct” and “# of Errors” but Excel used many different colors 

(and other settings) because each was plotted based upon phases. In other words, in this graph, there is 

“Baseline Phase” and three “Intervention Phases.” As a result, eight different colors are shown. To 

correct for this, do the following for all “Words Correct” items and then “# of Errors.” For “Words 

Correct” do the following: 

 Click only ONE TIME on the first (Baseline) data line for “Words Correct.” One or more of the 

markers will now have a box around it. In this instance, the first marker was highlighted. It is 

VERY IMPORTANT than the line ONLY be clicked on one time (more on this in a moment). 

 Right click, one time, on the same line, then select “Format Data Series” from the menu. The 

following window will appear: 
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16 

 Select “Marker Options” > “Built-in,” select the diamond type (in this case, no changes had to be 

made), then change the size to “4”: 
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 Select “Marker Fill” > “Solid Fill,” then select the color of the line that ALL “Word Correct” lines 

should have when they have all been changed. In this case, green was selected. 

 

 
 

 Select “Line Color” > “Solid Line,” then select the color of the line that ALL “Word Correct” lines 

should have when they have all been changed. In this case, green was selected. 
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 Select “Line Style” and customize any settings (as desired) here. In this case, the “Width” was 

changed to “1.5 pt”: 
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 Select “Marker Line Color” > “Solid Line,” then select the color of the line that ALL “Word 

Correct” lines should have when they have all been changed. In this case, green was selected. 
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 Click “Close.” The graph will now appear as: 

 

Note that ONLY the first (upper right) line has changed. This process must now be repeated for EVERY 

set of data that represents “Words Correct.” To do this, click ONCE on each of the remaining three sets 

(olive, turquoise, and light blue), then repeat the process. (Warning, ONLY click on each set ONCE 

otherwise, a problem will occur.) When clicking on the olive line, four of my markers displayed boxes 

around them. Yes, this takes a lot of time. When finished, the chart will now appear as: 
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This process must now be repeated for all “# of Errors” data. Be sure to select a different color and 

marker for this information (the example below changed the color to red and the marker to a triangle). 

Also be sure to change all other settings to match those previously used (e.g., the marker size set to “4” 

and the line width should be set to “1.5 pt”). When completed, the graph will appear as: 

 

 

The graph is now beginning to take shape. At this point, it’s time to clean up the legend (Excel created a 

label for each item based upon the number of phases that each has). To take care of this: 

 Click ONE time on the legend and a box will appear around it. 

 Click on each label that is to be removed; a box will now appear around just that item, then click 

“Delete.” 

 For this example, I left the top two labels and deleted all of the others (except for the one 

labeled “Dummy X” – that one will be removed later). The graph will now appear as: 
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The next step is to add phase lines and requires that some new data points to the graph. These were 

previously added to the data (listed above) and include:  

 Phase name (this is not graphed, it is only listed to help label the data), 

 Phase Line: This value represents where, exactly, on the X axis that the phase line is to appear. 

In the graph, Phase 1 begins on Session 4, Phase 2 begins on Session 14, and Phase 3 begins on 

Session 34. In order to place the phase lines appropriately, 0.5 must be subtracted from the 

point that the each phase begins (e.g., the lines will appear at 3.5, 13.5, 33.5 respectively) 

 Phase Line Y: this represents the height of the Y axis and is therefore set to 40 for each phase. 

To add phase lines: 

 Click once on the graph. Make sure that no items in the graph have boxes around them. 

 Right click on the graph. This will display a menu.  

 Click “Select Data.” This will display the following window: 

 
 

 Click the “Add” button, the following will appear: 
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 Enter “Phase Lines” in the “Series Name” box: 

 

 Click on the box/button to the left of “Select Range” (Under “Series X Values). The following will 

appear: 

 

 
 

 Next, highlight all of the cells under “Phase Line X“ in the data (I include all cells in that column 

that have the potential to contain a value). 

 Click the box/button on the right and the following will now appear: 

 

 
 

 Click on the box/button to the left of “= 1” (Under “Series Y Values). The following will appear: 
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 Next, highlight all of the cells under “Phase Line Y” (I include all cells in that column that have 

the potential to contain a value). 

 Click the box/button on the right and the following will now appear: 

 
 

 Click “OK” 

 Click OK again. 

 The graph should now appear as: 

 

 

 Notice the gray diamonds near the top. Click on just ONE of these. One or more of these will 

now have a box around it (it may not be the one that was clicked). 

 Select the “Layout Tab” (on the Excel Ribbon at the top). 

 Select “Error Bars” (if this is not visible, it may appear if you make the Excel window wider on 

your screen) and a menu will appear.  
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 Select “More Error Bar Options” and the following will appear: 

 

 
 

 Under “End Style” select “No Cap.” 
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 Under “Error Amount” select “Fixed value” and enter the height of the Y axis (in this case, 40). 

The window will now appear as: 
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 Now select “Line Color” > “Solid line” and then pick a color for the phase line (black is used in 

this example): 

 

 

 Select “Line Style” and customize as desired. In this example, “Dash type” was changed to a 

dashed line. 
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 Click “Close.” The graph will now appear as: 

 

 The phase lines now need to be “cleaned up” to remove the markers and lines at the top. The 

remove the lines, click on one of them and circles will appear on the ends of all of them. Hit the 

“Delete” key and they will disappear. The graph will now appear as: 

 

 To remove the markers, click on ONE of them, a box should appear around one or more of them 

(it may not be the one you clicked). 

 Right click on one of the markers (it doesn’t matter which one) and select “Format Data Series” 

from the menu that popped up. 
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 Select “Marker Options” and then “None”: 

 

 The graph should now appear as: 
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Labels can now be added to identify each phase. To do so: 

 Click the “Layout” tab on the Ribbon then select “Text Box.” The cursor will change to an 

inverted cross. Place the curson on the graph where the label is to be added. Left click and then 

enter the text (in this example, “Phase 1” was added): 

 

 
 

 Add the remaining labels: 

 

 

In order to customize the labels on the X axis, it’s necessary to use an “Add-in” called “Rob Bovey's XY 

Chart Labeler.” (It’s available for free at: http://www.appspro.com/) This add-in is free and 

should be installed before continuing. If need be, save your data, close Excel, and then 

install the add-in. After the add-in has been installed, a new tab, “XY Chart Labels” will 

appear on the Ribbon. Return to this section to continue.  

Instructions on how to change the labels may be found at: 

http://peltiertech.com/Excel/Charts/Y_CategoryAxis.html Unfortunately, the instructions are for 

labeling the Y axis but the procedures are a bit simpler for the X axis. In this example, it is desirable to 

differentiate between baseline and intervention sessions on the graph (as it was important to conduct 

40 sessions of the intervention, Phase 2 began after Session 10 and Phase 3 began after Session 30). 

Relabeling the graph will make the easier to understand (even though we also labeled each phase in the 

previous step). To do this: 

http://www.appspro.com/
http://peltiertech.com/Excel/Charts/Y_CategoryAxis.html
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 Click on the “XY Chart Labels” tab. A window will appear: 

 

 
 

 Select “Dummy X” from the dropdown box under “Select a Data Series to Label” 

 

 
 

 Click on the button on the left side of the box under “Select a Label Range” and the following 

will appear: 
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 With the mouse, go to the data and highlight the information found in the column “X Axis 

Labels.” Highlight all cells that have the potential to contain data (e.g., all cells for Sessions 1 to 

50” 

 

 Click on the blue/red button that appears on the right side and the following will appear: 

 

 
 

 Click on the dropdown box for “Select a Label Position” and select “Below”: 
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 The graph will now appear as: 

 

 As two sets of labels now show, it’s necessary to hide (not remove) the original one. To do this, 

click on one of the labels that belongs to the original. If the correct set is select, a box will 

appear around it. 
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 Right click on the box and select “Format axis” from the menu that appears: 
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 Change “Major tick mark type” to “None,” “Minor tick mark type” to “Outside,” and “Axis 

labels” to “None.” 
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 Click “Close” and the graph will now appear as: 

 

 

It may be necessary to change the size of the graph or the “Sessions” label.  If so, the graph may appear 

as: 

 

The “Dummy X” data  should also be hidden by: 

 Clicking anywhere on the “Dummy X” data once. Dots will appear on the data if this is 

successful. 
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 Right click on the same data and the following window will open: 

 

 

 Click on “Marker Options” > “None.” 

 Click on “Line Color” > “No line.” 

  



39 

 Click “Close” and the graph will now appear as: 

 

 

 The “Dummy X” and “Phase Line” labels may now be removed as described above. 

 The graph should now appear as: 

 

 To eliminate wasted space, the remaining legend may be moved. One way to accomplish this is 

to click on the legend once – a box will appear around it. 
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 Right click on the box and select “Format Legend.” The following window will open: 

 

 Uncheck the “Show the legend without overlapping the chart” box. 
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Resize, move any elements as desired, and you’re done! 

 


